Project

General

Profile

Bug #11685

rbinstall does not set Gem specification permission correctly

Added by arton (Akio Tajima) almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0preview1 (2015-11-11 trunk 52539) [x86_64-linux]
[ruby-dev:49343]

Description

rbinstall.rb does not set Gem specification permission while installing rubygems.
It seems line751 - 756 and 763 - are conflicting and it skips lines after 762.


Related issues

Has duplicate Ruby master - Bug #11691: Permission denied @ rb_sysopen did_you_mean-1.0.0.beta3.gemspecClosedhsbt (Hiroshi SHIBATA)Actions
#1

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Has duplicate Bug #11691: Permission denied @ rb_sysopen did_you_mean-1.0.0.beta3.gemspec added
#2

Updated by hsbt (Hiroshi SHIBATA) over 4 years ago

  • Status changed from Open to Closed

Applied in changeset r52585.


  • tool/rbinstall.rb: fix wrong permission for gem specification without zlib runtime. [Bug #11685][ruby-dev:49343]

Also available in: Atom PDF