Project

General

Profile

Bug #11399

Regexp's free-spacing mode adding whitespace to character classes

Added by sos4nt (Stefan Schüßler) about 4 years ago. Updated 12 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:70148]

Description

The free-spacing mode (x-option) does not ignore whitespace within character classes:

r = /[a
  # comment
b]/x

" \nab".scan(r)
#=> [" ", "\n", "a", "b"]

I would expect a regular expression that's equivalent to /[ab]/

History

Updated by jeremyevans0 (Jeremy Evans) 12 days ago

  • Status changed from Open to Rejected

This is not a bug. The documentation suggestions the use of character classes if you want to match whitespace (https://docs.ruby-lang.org/en/trunk/regexp_rdoc.html#label-Free-Spacing+Mode+and+Comments).

Also available in: Atom PDF