Project

General

Profile

Bug #11223

Rake SignalException: SIGSEGV

Added by quang319 (Quang Nguyen) about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.2.2p95
Backport:
[ruby-core:69467]

Description

I having this problem whenever I try to perform a rake on Cmock. Any guidance would be greatly appreciated.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\qnguyen>cd cmock

C:\Users\qnguyen\cmock>bundle update
Fetching gem metadata from http://rubygems.org/.........
Fetching version metadata from http://rubygems.org/..
Resolving dependencies...
Using rake 10.4.2
Using bundler 1.10.3
Using constructor 2.0.0
Using diy 1.1.2
Using minitest 5.7.0
Using require_all 1.3.2
Bundle updated!

C:\Users\qnguyen\cmock>bundle exec rake --trace
** Invoke default (first_time)
** Invoke test (first_time)
** Invoke clobber (first_time)
** Invoke clean (first_time)
** Execute clean
** Execute clobber
** Invoke prep_system_tests (first_time)
** Invoke C:/Users/qnguyen/cmock/test/system/generated (first_time)
** Execute C:/Users/qnguyen/cmock/test/system/generated
mkdir -p C:/Users/qnguyen/cmock/test/system/generated
** Invoke C:/Users/qnguyen/cmock/test/system/build (first_time)
** Execute C:/Users/qnguyen/cmock/test/system/build
mkdir -p C:/Users/qnguyen/cmock/test/system/build
** Execute prep_system_tests
** Invoke test:units (first_time)
** Execute test:units
C:/Ruby22/bin/ruby.exe -I"lib" -I"C:/Ruby22/lib/ruby/2.2.0" "C:/Ruby22/lib/ruby/
2.2.0/rake/rake_test_loader.rb" "test/unit/*_test.rb"
rake aborted!
SignalException: SIGSEGV
C:/Ruby22/lib/ruby/2.2.0/rake/testtask.rb:106:in `block (3 levels) in define'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils.rb:57:in `call'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils.rb:57:in `sh'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils_ext.rb:37:in `sh'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils.rb:96:in `ruby'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils_ext.rb:37:in `ruby'
C:/Ruby22/lib/ruby/2.2.0/rake/testtask.rb:104:in `block (2 levels) in define'
C:/Ruby22/lib/ruby/2.2.0/rake/file_utils_ext.rb:58:in `verbose'
C:/Ruby22/lib/ruby/2.2.0/rake/testtask.rb:100:in `block in define'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:240:in `call'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:240:in `block in execute'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:235:in `each'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:235:in `execute'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:179:in `block in invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/monitor.rb:211:in `mon_synchronize'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:172:in `invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:201:in `block in invoke_prerequisites'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:199:in `each'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:199:in `invoke_prerequisites'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:178:in `block in invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/monitor.rb:211:in `mon_synchronize'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:172:in `invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:201:in `block in invoke_prerequisites'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:199:in `each'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:199:in `invoke_prerequisites'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:178:in `block in invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/monitor.rb:211:in `mon_synchronize'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:172:in `invoke_with_call_chain'
C:/Ruby22/lib/ruby/2.2.0/rake/task.rb:165:in `invoke'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:150:in `invoke_task'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:106:in `block (2 levels) in top_lev
el'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:106:in `each'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:106:in `block in top_level'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:115:in `run_with_threads'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:100:in `top_level'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:78:in `block in run'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:176:in `standard_exception_handling
'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:75:in `run'
C:/Ruby22/bin/rake:33:in `<main>'
Tasks: TOP => default => test => test:units

C:\Users\qnguyen\cmock>

Related issues

Is duplicate of Ruby master - Bug #10978: [mswin32, mswin64] SignalException: SIGSEGVClosedActions

History

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback

Couldn't you show small code to reproduce it?

Updated by phasis68 (Heesob Park) about 4 years ago

It is a duplicate of Bug #10978 or #11089

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Status changed from Feedback to Closed

Updated by usa (Usaku NAKAMURA) about 4 years ago

  • Backport deleted (2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN)
#5

Updated by usa (Usaku NAKAMURA) about 4 years ago

  • Is duplicate of Bug #10978: [mswin32, mswin64] SignalException: SIGSEGV added

Also available in: Atom PDF