Project

General

Profile

Bug #10978

[mswin32, mswin64] SignalException: SIGSEGV

Added by Javix (Sergueï Cambour) over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:<unknown>]

Description

I have an error when running rake command on a simple minitest demo project:

C:\Users\XXXX\Documents\projects\tests_projects\minitest-project>rake --trace
** Invoke default (first_time)
** Invoke test (first_time)
** Execute test
rake aborted!
SignalException: SIGSEGV
C:/Ruby22-x64/lib/ruby/2.2.0/rake/testtask.rb:106:in `block (3 levels) in define'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils.rb:57:in `call'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils.rb:57:in `sh'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils_ext.rb:37:in `sh'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils.rb:96:in `ruby'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils_ext.rb:37:in `ruby'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/testtask.rb:104:in `block (2 levels) in define'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/file_utils_ext.rb:58:in `verbose'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/testtask.rb:100:in `block in define'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:240:in `call'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:240:in `block in execute'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:235:in `each'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:235:in `execute'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:179:in `block in invoke_with_call_chain'
C:/Ruby22-x64/lib/ruby/2.2.0/monitor.rb:211:in `mon_synchronize'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:172:in `invoke_with_call_chain'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:201:in `block in invoke_prerequisites'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:199:in `each'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:199:in `invoke_prerequisites'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:178:in `block in invoke_with_call_chain'
C:/Ruby22-x64/lib/ruby/2.2.0/monitor.rb:211:in `mon_synchronize'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:172:in `invoke_with_call_chain'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/task.rb:165:in `invoke'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:150:in `invoke_task'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:106:in `block (2 levels) in top_level'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:106:in `each'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:106:in `block in top_level'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:115:in `run_with_threads'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:100:in `top_level'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:78:in `block in run'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:176:in `standard_exception_handling'
C:/Ruby22-x64/lib/ruby/2.2.0/rake/application.rb:75:in `run'
C:/Ruby22-x64/bin/rake:33:in `<main>'
Tasks: TOP => default => test

OS: Windows 7 Enterprise, SP1, 64 bits
Ruby version:ruby 2.2.1p85 (2015-02-26 revision 49769) [x64-mingw32]
Rake version: rake (10.4.2)

Files

minitest-project.zip (1.84 KB) minitest-project.zip project example Javix (Sergueï Cambour), 03/16/2015 08:50 AM

Related issues

Is duplicate of Ruby master - Bug #10941: SIGSEGV caused by Rake on WindowsClosedActions
Has duplicate Ruby master - Bug #11223: Rake SignalException: SIGSEGVClosedActions

Associated revisions

Revision 7d7aec24
Added by nagachika (Tomoyuki Chikanaga) about 4 years ago

merge revision(s) 49859,49861,49865: [Backport #10941] [Backport #10978] [Backport #11089]

    * dir.c (replace_real_basename): shouldn't create Ruby object before
      the object system is loaded.
      [ruby-core:68430] [Bug #10941]

    * dir.c (replace_real_basename): need to check the return value of
      GLOB_REALLOC().

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@50545 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50545
Added by nagachika (Tomoyuki Chikanaga) about 4 years ago

merge revision(s) 49859,49861,49865: [Backport #10941] [Backport #10978] [Backport #11089]

* dir.c (replace_real_basename): shouldn't create Ruby object before
  the object system is loaded.
  [ruby-core:68430] [Bug #10941]

* dir.c (replace_real_basename): need to check the return value of
  GLOB_REALLOC().

History

#1

Updated by phasis68 (Heesob Park) over 4 years ago

I guess this issue is a duplicate of Bug #10941

#2

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Is duplicate of Bug #10941: SIGSEGV caused by Rake on Windows added
#3

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Status changed from Open to Closed

I think so, too.

#4

Updated by nagachika (Tomoyuki Chikanaga) about 4 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE

fixes are backported into ruby_2_2 branch at r50545 for #10941.

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Description updated (diff)
#6

Updated by usa (Usaku NAKAMURA) about 4 years ago

  • Has duplicate Bug #11223: Rake SignalException: SIGSEGV added

Also available in: Atom PDF