Project

General

Profile

Bug #1093

make test fails

Added by gdonald (Greg Donald) about 10 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-darwin9.6.0]
Backport:
[ruby-core:21791]

Description

=begin
[...]
#223 test_io.rb:11:in `':
begin
require "io/nonblock"
r, w = IO.pipe
w.nonblock = true
w.write_nonblock("a" * 100000)
w.nonblock = false
t1 = Thread.new { w.write("b" * 4096) }
t2 = Thread.new { w.write("c" * 4096) }
sleep 0.5
r.sysread(4096).length
sleep 0.5
r.sysread(4096).length
t1.join
t2.join
rescue LoadError
end
#=> not finished in 10 seconds [ruby-dev:32566]
FAIL 1/928 tests failed
make: *** [btest-ruby] Error 1
=end


Related issues

Is duplicate of Ruby trunk - Bug #1066: Frequent failure: test_io.rb test 2 on OS X 10.5.6Rejected01/28/2009Actions

History

#1

Updated by akr (Akira Tanaka) about 10 years ago

  • Assignee set to akr (Akira Tanaka)

=begin

=end

#2

Updated by akr (Akira Tanaka) about 10 years ago

=begin
closed because duplicated.
=end

#3

Updated by akr (Akira Tanaka) about 10 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF