Project

General

Profile

Feature #10797

`inherit` parameter for `..._defined?` methods in Module

Added by sawa (Tsuyoshi Sawada) about 5 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:67870]

Description

Module#const_defined? takes an optional argument inherit with default value true to control whether to consider inheritance. But the following methods do not:

  • Module#method_defined?
  • Module#private_method_defined?
  • Module#protected_method_defined?
  • Module#public_method_defined?

They only allow what would correspond to inherit = true. I request an optional argument inherit with default value true to be added to these methods to control whether inheritance should be considered.


Related issues

Is duplicate of Ruby master - Feature #14944: Support optional inherit argument for Module#method_defined?ClosedActions

Updated by sawa (Tsuyoshi Sawada) about 2 months ago

This proposal was adopted in Ruby 2.6 (and is mentioned in the context of #14944, which is actually a duplicate of the current issue). Please close this issue.

#2

Updated by Eregon (Benoit Daloze) about 2 months ago

  • Status changed from Open to Closed
#3

Updated by Eregon (Benoit Daloze) about 2 months ago

  • Is duplicate of Feature #14944: Support optional inherit argument for Module#method_defined? added

Also available in: Atom PDF