Project

General

Profile

Bug #10650

[PERF] bm_hash_keys and bm_hash_values

Added by tgxworld (Guo Xiang Tan) about 5 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:67134]

Description

Hi!

Benchmarks bm_hash_keys and bm_hash_values seemed to have gotten slower after a commit between e23d1736797f9b7170c80a7470b8e5cecd308105 and c73c34e27f028b6bcada9e5cd9a2961a822fc813.

You may view the benchmark result graphs at https://railsbench.herokuapp.com/tgxworld/ruby?utf8=%E2%9C%93&result_types%5B%5D=hash_keys&result_types%5B%5D=hash_values&commit=Submit.

On my builder, it is roughly 10%-11% slower. Not sure if the results are significant but I wish to bring it up. Thanks in advance!

History

Updated by nobu (Nobuyoshi Nakada) about 5 years ago

Guo Xiang Tan wrote:

You may view the benchmark result graphs at https://railsbench.herokuapp.com/tgxworld/ruby?utf8=%E2%9C%93&result_types%5B%5D=hash_keys&result_types%5B%5D=hash_values&commit=Submit.

Seems there are 2 results of same commit, c73c74e, and the difference is between them.
That means it caused by other than the ruby source, or one of them is wrong?

Updated by tgxworld (Guo Xiang Tan) about 5 years ago

Hi Nobu,

Seems like there is a bug with the labels on the site when rendering multiple graphs. Please see the below links for the individual graphs.

bm_hash_keys: http://rubybench.org/ruby/ruby/commits?result_type=hash_keys
bm_hash_values: http://rubybench.org/ruby/ruby/commits?result_type=hash_values

The commits that caused the regression should be one of this. https://github.com/ruby/ruby/compare/b65c619058864442dd7e283e1eec3093a8a7e86e...3a26241da3aec3d20dfc408a32de1c539455c89b. Do let me know if you need more information. Thanks!

Updated by mame (Yusuke Endoh) about 1 month ago

  • Status changed from Open to Closed

The benchmark has been greatly improved (about 3 times) since this ticket was open. So I close this ticket.

Still, it might be worth investigating the commits in question, but unfortunately, there is no one who is willing to do. If anyone is interested, the contribution is welcome.

Also available in: Atom PDF