Project

General

Profile

Actions

Bug #1058

closed

Ruby 1.9.1 make install fails on mingw due to rdoc

Added by cfis (Charlie Savage) almost 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
Backport:
[ruby-core:21582]

Description

=begin
I can successfully build 1.9.1 from head, using mingw on Vista and gcc 3.4.5.

$ ./configure CPPFLAGS=-I/usr/local/include LDFLAGS=-L/usr/local/lib --prefix=c:/Development/ruby-1.9.1

$ make

Then I run:

$ make install
./miniruby.exe -I./lib -I.ext/common -I./- -r./ext/purelib.rb ./instruby.rb --m
ake="make" --dest-dir="" --extout=".ext" --mflags="" --make-flags="" --data-mode
=0644 --prog-mode=0755 --installed-list .installed.list --mantype="man"
installing binary commands
installing command scripts
installing library scripts
installing headers
installing manpages
installing extension objects
installing extension scripts
creating default gem directories
Generating RDoc documentation
./miniruby.exe -I./lib -I.ext/common -I./- -r./ext/purelib.rb ./runruby.rb --extout=.ext -- "./bin/rdoc" --all --ri --op ".ext/rdoc" "."
c:/Development/src/ruby-1.9.1/lib/yaml.rb:9:in require': wrong argument type Fixnum (expected Class) (TypeError) from c:/Development/src/ruby-1.9.1/lib/yaml.rb:9:in <top (required)>'
from c:/Development/src/ruby-1.9.1/lib/rubygems/config_file.rb:7:in require' from c:/Development/src/ruby-1.9.1/lib/rubygems/config_file.rb:7:in <top (required)>'
from c:/Development/src/ruby-1.9.1/lib/rubygems.rb:862:in require' from c:/Development/src/ruby-1.9.1/lib/rubygems.rb:862:in <top (required)>'
from c:/Development/src/ruby-1.9.1/lib/rdoc/ri/paths.rb:37:in require' from c:/Development/src/ruby-1.9.1/lib/rdoc/ri/paths.rb:37:in module:Paths'
from c:/Development/src/ruby-1.9.1/lib/rdoc/ri/paths.rb:22:in <top (required)>' from c:/Development/src/ruby-1.9.1/lib/rdoc/options.rb:4:in require'
from c:/Development/src/ruby-1.9.1/lib/rdoc/options.rb:4:in <top (required)>' from c:/Development/src/ruby-1.9.1/lib/rdoc/rdoc.rb:13:in require'
from c:/Development/src/ruby-1.9.1/lib/rdoc/rdoc.rb:13:in <top (required)>' from ./bin/rdoc:11:in require'
from ./bin/rdoc:11:in `'
make: *** [rdoc] Error 1

Rdoc blows up.
=end

Actions #1

Updated by cfis (Charlie Savage) almost 14 years ago

=begin
After installation:

$ irb

require 'yaml'

TypeError: wrong argument type Fixnum (expected Class)
from c:/Development/ruby-1.9.1/lib/ruby/1.9.1/yaml.rb:9:in require' from c:/Development/ruby-1.9.1/lib/ruby/1.9.1/yaml.rb:9:in <top (required)>'
from (irb):10:in require' from (irb):10 from c:/Development/ruby/bin/irb:13:in '

So looks like this is just a yaml issue, not an rdoc issue.

=end

Actions #2

Updated by cfis (Charlie Savage) almost 14 years ago

=begin
Building with VC++ 2008 works as expected. So this is limited to YAML + mingw somehow.
=end

Actions #3

Updated by nobu (Nobuyoshi Nakada) almost 14 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
Applied in changeset r21795.
=end

Actions #4

Updated by cfis (Charlie Savage) almost 14 years ago

=begin
Confirmed fixed - thanks Nobu.
=end

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0