Project

General

Profile

Bug #10390

BUG] Segmentation fault at 0xbf3eeedc

Added by itsNikolay (Nikolay Ponomarev) over 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.1.2
Backport:
[ruby-core:65739]

Description

I've got segmentation fault on ruby 1.9.3 and 2.1.2
when starting rspec task
@myronmatson said that is ruby core issue, thus i post it here
https://github.com/rspec/rspec-dev/issues/52
Full listing of output in attachment
Thanks for support!

> rspec
Warning: You're using Rubygems 1.8.23.2 with Spring. Upgrade to at least Rubygems 2.1.0 and run `gem pristine --all` for better startup performance.
Run options: include {:focus=>true}

All examples were filtered out; ignoring {:focus=>true}
...../home/itsnikolay/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/rspec-core-3.1.7/lib/rspec/core/memoized_helpers.rb:242: [BUG] Segmentation fault at 0xbf3eeedc
ruby 2.1.2p95 (2014-05-08 revision 45877) [i686-linux]

-- Control frame information -----------------------------------------------
c:9386 p:0000 s:32886 e:002885 LAMBDA /home/itsnikolay/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/rspec-core-3.1.7/lib/rspec/core/memoized_helpers.rb:242 [FINISH]
c:9385 p:0007 s:32884 e:002883 LAMBDA /home/itsnikolay/projects/CUSTOMERS/sendit_parsers/spec/models/calculator_spec.rb:34 [FINISH]
c:9384 p:0015 s:32882 e:002878 BLOCK  /home/itsnikolay/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/rspec-core-3.1.7/lib/rspec/core/memoized_helpers.rb:242 [FINISH]
c:9383 p:---- s:32876 e:002875 CFUNC  :fetch
c:9382 p:0011 s:32872 e:002871 LAMBDA /home/itsnikolay/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/rspec-core-3.1.7/lib/rspec/core/memoized_helpers.rb:242 [FINISH]
c:9381 p:0007 s:32870 e:002869 LAMBDA /home/itsnikolay/projects/CUSTOMERS/sendit_parsers/spec/models/calculator_spec.rb:34 [FINISH]
c:9380 p:0015 s:32868 e:002864 BLOCK  /home/itsnikolay/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/rspec-core-3.1.7/lib/rspec/core/memoized_helpers.rb:242 [FINISH]

Files

stderr.txt (2.6 MB) stderr.txt itsNikolay (Nikolay Ponomarev), 10/16/2014 01:40 AM

Updated by itsNikolay (Nikolay Ponomarev) over 5 years ago

Get this when I try to merge.

FactoryGirl.define do
  factory :calculator_params, class: Hash do
    initialize_with do
      { from: { city_id: '0987654321' },
        to:   { city_id: '12345678' },
        weight: 3,
        variant: 'ДД',

        length: 100,
        width:  100,
        height: 100,
        parcel_type: {
          id: 1,
          name: 'Одежда',
        },
        packaging: true,
      }
    end
  end
end

and test

let(:params) { build :calculator_params }
let(:new_params) { params.merge!( { from: { city_id: '195851995' }, to: { city_id: '48951627' }} )

Updated by hsbt (Hiroshi SHIBATA) about 4 years ago

  • Status changed from Open to Feedback
  • Assignee deleted (zzak (Zachary Scott))
  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN to 2.1: UNKNOWN

Can you try with Ruby 2.1.10 or 2.2/2.3?

#3

Updated by jeremyevans0 (Jeremy Evans) 11 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF