shan (Shannon Skipper)

  • Registered on: 12/23/2012
  • Last connection: 12/12/2019




07:44 PM Ruby master Feature #16341: Proposal: Set#to_proc and Hash#to_proc
Nondv (Dmitry Non) wrote:
> Speaking of hashes, they could implement implicit proc conversion as well:
> ```rub...
shan (Shannon Skipper)


01:33 AM Ruby master Feature #16275: Revert `.:` syntax
I've already fallen into using ` .:` in 2.7. I'd personally miss `.:` since it feels super natural to me. shan (Shannon Skipper)


08:26 PM Ruby master Feature #16261: Enumerable#each_splat and Enumerator#splat
This reminds me of a neat post showing applicatives in pictures:,_applicativ... shan (Shannon Skipper)


04:00 PM Ruby master Misc #16130: [Discussion / Ideas] Finding a good name for the concept of/behind guilds - primarily the NAME
A Braid of Threads also makes sense in that metaphor. Twine is another option similar to Rope or Yarn.
I do like t...
shan (Shannon Skipper)


11:51 PM Ruby master Feature #16113: Partial application
I like Hanmac's idea.
``` ruby
Seems very close to:
``` ruby
shan (Shannon Skipper)
11:42 PM Ruby master Feature #16120: Omitted block argument if block starts with dot-method call
A bit of an aside, but it's often just as fast to do two iterations with small collections, since the shorthand parse... shan (Shannon Skipper)


01:28 AM Ruby master Feature #16113: Partial application
An aside, but I took a stab at a pure Ruby implementation of keyword argument currying: shan (Shannon Skipper)


06:01 PM Ruby master Feature #16011: Digit grouping
``` ruby
class Integer
def delimited(by: ',', digits: 0, padding: '0', every: 3)
extra_padding_size = digits...
shan (Shannon Skipper)


03:29 PM Ruby master Feature #15799: pipeline operator
Seeing `|>` my assumption would be that you could use it in the functional style, so you could do:
``` ruby
42 |>...
shan (Shannon Skipper)


10:09 AM Ruby master Feature #13821: Allow fibers to be resumed across threads
If automatic detection of whether a Fiber is shareable across Threads isn't viable, it would be really, really nice t... shan (Shannon Skipper)

Also available in: Atom