General

Profile

taca (Takahiro Kambe)

Issues

Activity

01/09/2020

03:17 AM Ruby master Bug #16490 (Open): mkmf.rbの非互換な変更
tmailのrubygem 1.2.7.1をインストールする際に、
```
make "DESTDIR="
make: don't know how to make /usr/pkg/include/ruby-2.7.0/def...
taca (Takahiro Kambe)

12/16/2019

10:29 AM Ruby master Bug #16342: macOS + Ruby 2.6.0 以降で拡張ライブラリ内での waitpid() コールに失敗する
解決策を持っているわけでも何でもないのですが、気になった事項です。
Process#forkに対応するRuby本体のprocess.cを読むとC言語のレベルでfork(2)を行う前にいくつかの前準備を行っています。一方、GitHub...
taca (Takahiro Kambe)

09/29/2018

03:54 PM Ruby master Bug #14807: 2.6.0-preview2 segfaults on OpenBSD due to missing pthread_condattr_init call
Hi,
Wheather `PTHREAD_COND_INITIALIZER` is work on OpenBSD or not, it should be used for initialize `pthread_cond_...
taca (Takahiro Kambe)
03:43 PM Ruby master Bug #15178 (Open): Wrong paramaters passing to pthread_setname_np(3)
Ruby 2.6.0-preview2の動作を調べている途中で見つけました。
[Bug #9586]の修正r45713で、NetBSDの場合のpthread_setname_np(3)の引数を修正しています。
ここは第2引数と...
taca (Takahiro Kambe)

09/22/2018

06:08 PM Ruby master Bug #14807: 2.6.0-preview2 segfaults on OpenBSD due to missing pthread_condattr_init call
Hi,
The similar problem occurs on NetBSD 8.0_STABLE. (And I belive it would be occur on 7.2.)
`PTHREAD_COND_IN...
taca (Takahiro Kambe)

02/04/2018

12:51 PM Ruby master Bug #14439: build failed on NetBSD 7.1 with MJIT
In message <redmine.issue-14439.20180204122852.8b177c62b00fc2c1@ruby-lang.org>
on Sun, 04 Feb 2018 12:28:54 +0000 ...
taca (Takahiro Kambe)

07/25/2017

03:53 AM Ruby master Bug #13764: Ruby 2.3.4 build problem with "-fstack-check"
Please close this Issue since I posted to wrong language and I re-posted as Bug #13766. taca (Takahiro Kambe)
03:51 AM Ruby master Bug #13766 (Closed): Ruby 2.3.4 build problem with "-fstack-check"
pkgsrcで PKGSRC_USE_STACK_CHECK を yes に設定すると Ruby 2.3.4 のビルドに失敗します。
現象としては、tool/generic_erb.rb で encdb.h を生成する際に erb....
taca (Takahiro Kambe)

07/24/2017

02:04 PM Ruby master Bug #13764 (Rejected): Ruby 2.3.4 build problem with "-fstack-check"
pkgsrcで PKGSRC_USE_STACK_CHECK を yes に設定すると Ruby 2.3.4 のビルドに失敗します。
現象としては、tool/generic_erb.rb で encdb.h を生成する際に erb....
taca (Takahiro Kambe)

01/17/2015

02:25 PM Ruby master Bug #10750 (Closed): configure script has bashism on Ruby 2.2.0
On Ruby 2.2.0, configure script has bashism part and it cause syntax error:
~~~
./configure: 21262: Syntax error:...
taca (Takahiro Kambe)

Also available in: Atom