Project

General

Profile

Feature #17490

Updated by k0kubun (Takashi Kokubun) over 1 year ago

## Background 
 These days it's sometimes said that CRuby may add another lightweight JIT. Leaving `RubyVM::MJIT` under such In my understanding, MJIT is a situation might imply `RubyVM::MJIT` will codename like YARV which many people outside Ruby community are not impact the future JIT, but I think `MJIT.pause`/`MJIT.resume` should impact all JITs by default if `--jit` is going familiar with, so I've used JIT in NEWS or release notes to enable all avoid explaining the JITs. The current "M" part whenever we release a new version. However, because we have the name "MJIT" in one of our constants, we've had some naming will be confusing, and I think these features should named consistently with `--jit`. 

 I also think, although this feature inconsistency. For instance, --jit is for JIT developers anyway, we should not add many APIs to control JIT (for now I want JIT to be a feature where users don't need to think about tuning it, --mjit and having such APIs might end up letting people do that), and this naming change will contribute to discouraging APIs for a particular JIT. it's not consistent. 

 ## Proposal 
 Have the same constant as `RubyVM::JIT`, deprecate `RubyVM::MJIT` from Ruby 3.1, and remove the old one in Ruby 3.2. 

 ## Impact 
 This impacts only [Feature #14830] `RubyVM::MJIT.pause` / `RubyVM::MJIT.resume`, which is basically for k0kubun's own testing.

Back