Project

General

Profile

Feature #20925

Updated by Dan0042 (Daniel DeLorme) 4 days ago

I would like for this to become accepted syntax: 

	 condition1 
	 || condition2 
	
	 condition1 
	 && condition2 
	
	 condition1 
	 or condition2 
	
	 condition1 
	 and condition2 
	
 This is similar to how method chaining on the second line was added in Ruby 1.9 

	 expr 
	 .method 
	
 And it has the same advantage: when you have a multi-line expression, instead of hunting for the dot or boolean operator at the end of line1, it's right there at the beginning of line2, making the structure very obvious and readable. Please contrast: 

	 request.secret_key_base.present? && 
	   request.encrypted_signed_cookie_salt.present? && 
	   request.encrypted_cookie_salt.present? && 
	   request.use_authenticated_cookie_encryption 
	
	 request.secret_key_base.present? 
	   && request.encrypted_signed_cookie_salt.present? 
	   && request.encrypted_cookie_salt.present? 
	   && request.use_authenticated_cookie_encryption 

 The first expression must rely on indentation to communicate the multi-line nature of the condition, and even then it's not as immediately obvious as the second expression, where we can see easily and immediately that this is a multi-line `&&` condition. 

 This syntax is also similar to how a trailing comma is allowed in arrays and hashes (and method calls since Ruby 1.9), with the same advantage. It makes for a cleaner diff when you add an element to the array/hash/conditional. Taking the previous example, imagine we are adding the condition `&& request.use_authenticated_cookie_encryption`. Now contrast the diff between the two styles: 

	   request.secret_key_base.present? && 
	     request.encrypted_signed_cookie_salt.present? && 
	 -          request.encrypted_cookie_salt.present? 
	 +          request.encrypted_cookie_salt.present? && 
	 +     request.use_authenticated_cookie_encryption 
	
	   request.secret_key_base.present? 
	     
	   && request.encrypted_signed_cookie_salt.present? 
	     
	   && request.encrypted_cookie_salt.present? 
	 +     && request.use_authenticated_cookie_encryption 

 Based on the above I would say this syntax is natural and consistent with existing Ruby syntactical elements, and would greatly improve code readability.

Back