Project

General

Profile

Feature #9209

Struct instances creatable with named args

Added by rits (First Last) over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:58846]

Description

now that ruby supports named params it seems natural for Struct to make use of them.

Struct.new(:a).new(a: 1)


Related issues

Is duplicate of Ruby master - Feature #11925: Struct construction with kwargsClosedActions

History

Updated by herwinw (Herwin Quarantainenet) almost 3 years ago

This looks like a duplicate of #11925 (or maybe the other way around, but the other ticket includes more information)

#2

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Is duplicate of Feature #11925: Struct construction with kwargs added

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Status changed from Open to Closed

please continue to issue #11925.

Also available in: Atom PDF