Project

General

Profile

Bug #7569

siphash.c / endian.h

Added by orban (Tuples Arefun) almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby-1.9.3-p327
Backport:
[ruby-core:50916]

Description

siphash.c includes endian.h, but on Solaris, there is no such file. BYTE_ORDER also does not exist.

There needs to be a different solution.

This makes it impossible to compile ruby.

SunOS abc.local 5.11 joyent_20120912T055050Z i86pc i386 i86pc Solaris


Related issues

Is duplicate of Backport193 - Backport #7347: 1.9.3p327 Build fails on Solaris 10 SPARC due to missing endian.hClosedusa (Usaku NAKAMURA)11/13/2012Actions
Is duplicate of Backport193 - Backport #7470: ruby 1.9.3-p327 compile failure in siphash.c on Solaris because of endian.hClosedusa (Usaku NAKAMURA)11/29/2012Actions

Also available in: Atom PDF