Project

General

Profile

Bug #7521

test_thr_kill(TestQueue) fails

Added by vo.x (Vit Ondruch) almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2012-12-04 trunk 38184) [i386-linux]
Backport:
[ruby-core:50590]

Description

=begin
I am observing following error on Fedora 19.

13) Failure:
test_thr_kill(TestQueue) [/builddir/build/BUILD/ruby-2.0.0-r38184/test/thread/test_queue.rb:106]:
only 0/2000 done in 30 seconds.

This test fails approximately every second build. Any help appreciated.
=end


Related issues

Related to Backport200 - Backport #8065: r39688 - test_queue.rb (test_thr_kill): reduce iterations from 2000 to 250. のバックポートClosed03/10/2013Actions

History

#1

Updated by usa (Usaku NAKAMURA) almost 7 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Assignee set to kosaki (Motohiro KOSAKI)
  • Target version set to 2.0.0

Updated by kosaki (Motohiro KOSAKI) almost 7 years ago

  • Status changed from Assigned to Feedback

My CentOS6 machine don't reproduce this issue. Can you please explain what change Fedora19 has?
Or, can you make smallest repro?

Updated by vo.x (Vit Ondruch) almost 7 years ago

  • Status changed from Feedback to Closed

I did not met this issue in recent days. It was probably just some temporary issue of Rawhide. Sorry for disturbing.

Updated by vo.x (Vit Ondruch) over 6 years ago

  • Status changed from Closed to Open

I reopening, since I met this issue again with ruby 2.0.0dev (2013-02-22 trunk 39387) [i386-linux]. This is my build log [1]. It happens just from time to time. Actually I did probably hundreds of build since the time I initially reported it and it strikes me as soon as I want to do official build for Fedora.

[1] http://koji.fedoraproject.org/koji/watchlogs?taskID=5043957

Updated by kosaki (Motohiro KOSAKI) over 6 years ago

  • Status changed from Open to Feedback

Again, please provide smallest reproducer.

thanks.

Updated by kosaki (Motohiro KOSAKI) over 6 years ago

I suspect this is the same with #8065.

Updated by vo.x (Vit Ondruch) over 6 years ago

Yesterday, I did 6 x 6 builds (i.e. 36 builds in total) on different platforms and every time at leas one failed. So I applied the r39728 from #8065, did again 6 x 6 builds and so far so good. Doing now official build and hope it will succeed as well. Thanks.

Updated by kosaki (Motohiro KOSAKI) over 6 years ago

  • Status changed from Feedback to Closed

thanks. then closing by duplicate.

Also available in: Atom PDF