Project

General

Profile

Bug #5377

Timezone Bug

Added by jan.pilz (Jan Pilz) over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
1.8.7, 1.9.1
Backport:
[ruby-core:39759]

Description

jpilz@jpilz:~$ irb
irb(main):001:0> Time.now
=> Wed Sep 28 14:26:19 +0200 2011
irb(main):002:0> Time.local(1981, 9, 27)
=> Sun Sep 27 00:00:00 +0200 1981
irb(main):003:0> Time.local(1981, 9, 28)
=> Mon Sep 28 00:00:00 +0100 1981
irb(main):004:0> Time.local(1996, 3, 31)
=> Sun Mar 31 00:00:00 +0100 1996
irb(main):005:0> Time.local(1996, 4, 1)
=> Mon Apr 01 00:00:00 +0200 1996
irb(main):006:0> Time.local(1981, 9, 27) + (60 * 60 * 24)
=> Sun Sep 27 23:00:00 +0100 1981
irb(main):007:0> Time.local(1981, 3, 31) + (60 * 60 * 24)
=> Wed Apr 01 00:00:00 +0200 1981

seems it Time.local changes timezone between 1981/09/28 and 1996/03/31 to +0100.

Same behaviour under ruby 1.8.7, 1.9.1 and jruby, windows and linux.

Best regards,
Jan

History

Updated by naruse (Yui NARUSE) over 7 years ago

  • Priority changed from 5 to Normal

Your area seems changed the timezone.
Where is the timezone?

Updated by jan.pilz (Jan Pilz) over 7 years ago

It's not a bug, it is switching between summer and wintertime.
Ruby is correct here. Please close...

Updated by ayumin (Ayumu AIZAWA) over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF