Project

General

Profile

Actions

Bug #5323

closed

Bug in CreateChild in win32.c

Added by jfrench (James French) almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
1.9.2-p290
Backport:
[ruby-core:39552]

Description

Revision 31811 by yugui (http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=31811) which was merged from the trunk contains a bug. It should be lstrlen instead of lstrlenW as its a char* not a wchar_t*. This has caused us a lot of problems with spawn failing spuriously.

This was introduced between 1.9.2-p180 and 1.9.2-p290 and should, IMO, make it into the next patch release of 1.9.2.


Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #5324: Bug in CreateChild in win32.cClosed09/14/2011Actions
Actions #1

Updated by marcandre (Marc-Andre Lafortune) over 10 years ago

  • Status changed from Open to Closed

Duplicate of #5325

Actions

Also available in: Atom PDF