Project

General

Profile

Bug #5194

exceptions caught compiling with clang 2.1 on OSX 10.7

Added by joneslee85 (Jones Lee) over 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
1.9.4dev
Backport:
[ruby-core:38978]

Description

Got exception when compiling ruby1.9.4dev with clang 2.1 (Xcode 4) on OSX Lion 10.7

Source SVN date: 16/08/2011

compiling ./enc/ascii.c
compiling ./enc/us_ascii.c
compiling ./enc/unicode.c
compiling ./enc/utf_8.c
generating newline.c ...
converter for universal_newline
converter for crlf_newline
converter for cr_newline
done. (0.06user 0.01system 0.02elapsed)
compiling newline.c
compiling ./missing/setproctitle.c
compiling dmyext.c
linking miniruby
internal:prelude:1: [BUG] Bus Error
ruby 1.9.4dev (2011-08-16) [x86_64-darwin11.0.0]

-- Control frame information -----------------------------------------------
c:0003 p:0002 s:0006 b:0006 l:000005 d:000005 TOP internal:prelude:1
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:002128 d:002128 TOP

-- Ruby level backtrace information ----------------------------------------
internal:prelude:1:in `'

-- C level backtrace information -------------------------------------------

See Crash Report log file under ~/Library/Logs/CrashReporter or
/Library/Logs/CrashReporter, for the more detail of.

-- Other runtime information -----------------------------------------------

  • Loaded script: ./miniruby

  • Loaded features:

    0 enumerator.so

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

make: *** [.rbconfig.time] Abort trap: 6


Files

make.log (11.7 KB) make.log cakepie (Cake Pie), 11/27/2011 05:13 AM

Related issues

Related to Ruby master - Bug #5082: test_context_switch(TestMarshal) was failed on OS X 10.7 (Lion)Closed07/23/2011Actions

History

Updated by joneslee85 (Jones Lee) over 8 years ago

More traces info

Process: miniruby [30619]
Path: /Users/USER/*/miniruby
Identifier: miniruby
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: gnumake [29787]

Date/Time: 2011-08-16 20:01:56.097 +1000
OS Version: Mac OS X 10.7 (11A511)
Report Version: 9

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGABRT)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000100a1a817

VM Regions Near 0x100a1a817:
--> __TEXT 00000001009d5000-0000000100bbd000 [ 1952K] r-x/rwx SM=COW /Users/USER/*
__DATA 0000000100bbd000-0000000100bd9000 [ 112K] rw-/rwx SM=PRV /Users/USER/*

Application Specific Information:
objc[30619]: garbage collection is OFF
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff970ffce2 __pthread_kill + 10
1 libsystem_c.dylib 0x00007fff8e6b17d2 pthread_kill + 95
2 libsystem_c.dylib 0x00007fff8e6a2a7a abort + 143
3 miniruby 0x0000000100a05d79 rb_bug + 185
4 miniruby 0x0000000100ab5e36 sigbus + 54
5 libsystem_c.dylib 0x00007fff8e703cfa _sigtramp + 26
6 miniruby 0x0000000100b0eb7e vm_exec_core + 2702 (vm.inc:494)
7 miniruby 0x0000000100b1a1ee vm_exec + 94 (vm.c:1182)
8 miniruby 0x0000000100b1a122 rb_iseq_eval + 402 (vm.c:1409)
9 miniruby 0x0000000100ab13b8 ruby_process_options + 1432 (ruby.c:1098)
10 miniruby 0x0000000100a0a1c0 ruby_options + 128 (eval.c:73)
11 miniruby 0x00000001009d61d7 main + 71 (main.c:38)
12 miniruby 0x00000001009d6184 start + 52

Thread 1:
0 libsystem_kernel.dylib 0x00007fff970ffdf2 __select + 10
1 miniruby 0x0000000100b296bc thread_timer + 380 (thread_pthread.c:1153)
2 libsystem_c.dylib 0x00007fff8e6af8bf _pthread_start + 335
3 libsystem_c.dylib 0x00007fff8e6b2b75 thread_start + 13

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000006 rcx: 0x00007fb58909c338 rdx: 0x0000000000000000
rdi: 0x0000000000000303 rsi: 0x0000000000000006 rbp: 0x00007fb58909c360 rsp: 0x00007fb58909c338
r8: 0x00007fff7e346fb8 r9: 0x00007fb58909c1e8 r10: 0x00007fff970ffd0a r11: 0xffffff80002d8240
r12: 0x0000000100e00028 r13: 0x0000000100d95600 r14: 0x00007fff7e349960 r15: 0x0000000100efff50
rip: 0x00007fff970ffce2 rfl: 0x0000000000000246 cr2: 0x0000000100b206c0
Logical CPU: 0

Binary Images:
0x1009d5000 - 0x100bbcfff +miniruby (??? - ???) /Users/USER/*/miniruby
0x7fff605d5000 - 0x7fff60609ac7 dyld (195.5 - ???) /usr/lib/dyld
0x7fff8e661000 - 0x7fff8e73efef libsystem_c.dylib (763.11.0 - compatibility 1.0.0) /usr/lib/system/libsystem_c.dylib
0x7fff8e786000 - 0x7fff8e78cff7 libunwind.dylib (30.0.0 - compatibility 1.0.0) /usr/lib/system/libunwind.dylib
0x7fff8e88d000 - 0x7fff8e897ff7 liblaunch.dylib (392.18.0 - compatibility 1.0.0) /usr/lib/system/liblaunch.dylib
0x7fff8e986000 - 0x7fff8e987ff7 libsystem_blocks.dylib (53.0.0 - compatibility 1.0.0) /usr/lib/system/libsystem_blocks.dylib
0x7fff8eae2000 - 0x7fff8eaeafff libsystem_dnssd.dylib (??? - ???) /usr/lib/system/libsystem_dnssd.dylib
0x7fff8ed5a000 - 0x7fff8ed77ff7 libxpc.dylib (77.16.0 - compatibility 1.0.0) /usr/lib/system/libxpc.dylib
0x7fff8ed78000 - 0x7fff8ed7afff libquarantine.dylib (36.0.0 - compatibility 1.0.0) /usr/lib/system/libquarantine.dylib
0x7fff8ed7b000 - 0x7fff8edbdff7 libcommonCrypto.dylib (55010.0.0 - compatibility 1.0.0) /usr/lib/system/libcommonCrypto.dylib
0x7fff8eec4000 - 0x7fff8eed2fff libdispatch.dylib (187.5.0 - compatibility 1.0.0) /usr/lib/system/libdispatch.dylib
0x7fff8f545000 - 0x7fff8f54afff libcompiler_rt.dylib (6.0.0 - compatibility 1.0.0) /usr/lib/system/libcompiler_rt.dylib
0x7fff904a7000 - 0x7fff904a8fff libdnsinfo.dylib (395.6.0 - compatibility 1.0.0) /usr/lib/system/libdnsinfo.dylib
0x7fff90b09000 - 0x7fff90b14ff7 libc++abi.dylib (14.0.0 - compatibility 1.0.0) /usr/lib/libc++abi.dylib
0x7fff90ba9000 - 0x7fff90baaff7 libremovefile.dylib (21.0.0 - compatibility 1.0.0) /usr/lib/system/libremovefile.dylib
0x7fff90ca8000 - 0x7fff90d8cdef libobjc.A.dylib (228.0.0 - compatibility 1.0.0) /usr/lib/libobjc.A.dylib
0x7fff912d5000 - 0x7fff91348fff libstdc++.6.dylib (52.0.0 - compatibility 7.0.0) /usr/lib/libstdc++.6.dylib
0x7fff92284000 - 0x7fff9228dfff libnotify.dylib (80.0.0 - compatibility 1.0.0) /usr/lib/system/libnotify.dylib
0x7fff92318000 - 0x7fff9231ffff libcopyfile.dylib (85.1.0 - compatibility 1.0.0) /usr/lib/system/libcopyfile.dylib
0x7fff92541000 - 0x7fff9257dfff libsystem_info.dylib (??? - ???) /usr/lib/system/libsystem_info.dylib
0x7fff935da000 - 0x7fff935dbfff libsystem_sandbox.dylib (??? - ???) /usr/lib/system/libsystem_sandbox.dylib
0x7fff93716000 - 0x7fff93743fe7 libSystem.B.dylib (159.0.0 - compatibility 1.0.0) /usr/lib/libSystem.B.dylib
0x7fff938ac000 - 0x7fff938b0fff libmathCommon.A.dylib (2026.0.0 - compatibility 1.0.0) /usr/lib/system/libmathCommon.A.dylib
0x7fff95682000 - 0x7fff95682fff libkeymgr.dylib (23.0.0 - compatibility 1.0.0) /usr/lib/system/libkeymgr.dylib
0x7fff960df000 - 0x7fff96154ff7 libc++.1.dylib (19.0.0 - compatibility 1.0.0) /usr/lib/libc++.1.dylib
0x7fff96596000 - 0x7fff96597fff libunc.dylib (24.0.0 - compatibility 1.0.0) /usr/lib/system/libunc.dylib
0x7fff970e9000 - 0x7fff97109fff libsystem_kernel.dylib (1699.22.73 - compatibility 1.0.0) /usr/lib/system/libsystem_kernel.dylib
0x7fff97606000 - 0x7fff9760bff7 libsystem_network.dylib (??? - ???) /usr/lib/system/libsystem_network.dylib
0x7fff977af000 - 0x7fff977fdff7 libauto.dylib (??? - ???) /usr/lib/libauto.dylib
0x7fff977fe000 - 0x7fff97803fff libcache.dylib (47.0.0 - compatibility 1.0.0) /usr/lib/system/libcache.dylib
0x7fff982a7000 - 0x7fff982adfff libmacho.dylib (800.0.0 - compatibility 1.0.0) /usr/lib/system/libmacho.dylib
0x7fff9a8ac000 - 0x7fff9a8b0fff libdyld.dylib (195.5.0 - compatibility 1.0.0) /usr/lib/system/libdyld.dylib

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 16505
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=54.1M resident=17.0M(31%) swapped_out_or_unallocated=37.1M(69%)
Writable regions: Total=74.5M written=140K(0%) resident=1388K(2%) swapped_out=0K(0%) unallocated=73.2M(98%)

REGION TYPE VIRTUAL
=========== =======
MALLOC 10.2M
MALLOC guard page 16K
STACK GUARD 4K
Stack 64.0M
__DATA 668K
__LINKEDIT 47.6M
__TEXT 6652K
shared memory 12K
=========== =======
TOTAL 129.0M

Updated by mrkn (Kenta Murata) about 8 years ago

  • Category set to build
  • Status changed from Open to Rejected
  • Priority changed from Normal to 3
  • Target version set to 1.9.4

Which revision did you build?

I tried to build r33019 with "Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)",
and it was succeeded including "make test".

If you can reproduce this issue with the latest revision of trunk,
I believe it may be due to your environment.

Updated by cakepie (Cake Pie) almost 8 years ago

I have the same issue. New MacBook Air, installed Xcode 4.2 through Appstore, never had GCC installed. I have not compiled anything else, modified my environment, or any special setup. It's a brand new machine.

Ruby 1.9.3-p0 (http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p0.tar.gz)

I did configure it with "--with-gcc=clang".

Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.2.0
Thread model: posix

Attached "make" output and crash report.

Updated by cakepie (Cake Pie) almost 8 years ago

Same problem on my iMac, which has been upgraded from Leopard.

Xcode 4.2 and "--with-gcc=clang".

Also available in: Atom PDF