Project

General

Profile

Backport #4861

Backport r31528 to 1.9.2

Added by 13k (Kiyoshi Murata) over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:36903]

Description

I see r31346 was merged but it actually has no effect on the issue (#4556) since the code isn't using the generated HAVE_* defines to check for SSLv2.


Related issues

Related to Ruby master - Feature #4556: Please add option which enable SSLv2 supportClosed04/06/2011Actions

Associated revisions

Revision 8a571111
Added by yugui (Yuki Sonoda) over 8 years ago

merges r31528 from trunk into ruby_1_9_2. fixes #4861.

    * ext/openssl/ossl_ssl.c: By trunk@31346, function check of SSLv2 is executed.
    However, the problem is not revised in this.
    This adds the control of using function of SSLv2 in made macro by function check.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@32382 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 32382
Added by yugui (Yuki Sonoda) over 8 years ago

merges r31528 from trunk into ruby_1_9_2. fixes #4861.

    * ext/openssl/ossl_ssl.c: By trunk@31346, function check of SSLv2 is executed.
    However, the problem is not revised in this.
    This adds the control of using function of SSLv2 in made macro by function check.

History

#1

Updated by naruse (Yui NARUSE) over 8 years ago

  • Project changed from Ruby master to Backport192
  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)
#2

Updated by yugui (Yuki Sonoda) over 8 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r32382.
Kiyoshi, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merges r31528 from trunk into ruby_1_9_2. fixes #4861.

    * ext/openssl/ossl_ssl.c: By trunk@31346, function check of SSLv2 is executed.
    However, the problem is not revised in this.
    This adds the control of using function of SSLv2 in made macro by function check.

Also available in: Atom PDF