Project

General

Profile

Bug #4699

Arrays - affectation

Added by scicasoft (Cheikh Sidya CAMARA) about 9 years ago. Updated about 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.8.7 (2010-01-10 patchlevel 249) [i486-linux]
[ruby-core:36202]

Description

a = [1,2,3]
b = a
b[1] = 10

the content of a : [1, 10, 3]

why the variables a and b point on the same space ?

a.object_id = b.boject_id

Updated by rue (Eero Saynatkari) about 9 years ago

This is a feature, not a bug.

Updated by sorah (Sorah Fukumori) about 9 years ago

  • Status changed from Open to Rejected

If a.object_id == b.object_id, this is a feature.

If a.object_id != b.object_id, this is a bug.

Also available in: Atom PDF