Project

General

Profile

Actions

Bug #4600

closed

date/date_parse.c errors are breaking MinGW build

Added by luislavena (Luis Lavena) about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.8.7 (2011-02-18 patchlevel 334) [i386-mingw32]
Backport:
[ruby-core:35860]

Description

=begin
Hello,

Recent commits to ext/date/date_parse are breaking the MinGW build. As revision 31323:

make[2]: Entering directory /c/Users/Luis/Projects/oss/oci/rubyinstaller/sandbox/ruby19_build/ext/date' generating date_core-i386-mingw32.def compiling ../../../../../../ruby/ext/date/date_core.c compiling ../../../../../../ruby/ext/date/date_parse.c ../../../../../../ruby/ext/date/date_parse.c: In function 'parse_ddd_cb': ../../../../../../ruby/ext/date/date_parse.c:1105:6: warning: implicit declaration of function 'index' ../../../../../../ruby/ext/date/date_parse.c:1105:11: warning: incompatible implicit declaration of built-in function 'index' compiling ../../../../../../ruby/ext/date/date_strftime.c compiling ../../../../../../ruby/ext/date/date_strptime.c linking shared-object date_core.so date_parse.o: In function parse_ddd_cb':
c:\Users\Luis\Projects\oss\oci\rubyinstaller\sandbox\ruby19_build\ext\date/../../../../../../ruby/ext/date/date_parse.c:1105: undefined reference to index' collect2: ld returned 1 exit status make[2]: *** [../../.ext/i386-mingw32/date_core.so] Error 1 make[2]: Leaving directory /c/Users/Luis/Projects/oss/oci/rubyinstaller/sandbox/ruby19_build/ext/date'
make[1]: *** [ext/date/all] Error 2
=end

Updated by naruse (Yui NARUSE) about 11 years ago

  • Status changed from Open to Assigned

=begin

=end

Updated by tadf (tadayoshi funaba) about 11 years ago

  • Status changed from Assigned to Closed

switch hitter does not support 1.8.x.
anyway, closed.

Updated by luislavena (Luis Lavena) about 11 years ago

Thank you tadayoshi funaba for fixing this.

I'm was trying to build ruby-trunk and use 1.8.7 as baseruby, that is why ruby -v mention 1.8.7

The issue is now solved.

Actions

Also available in: Atom PDF