Project

General

Profile

Bug #4567

BigDecimal::ROUND_HALF_DOWN

Added by semmons99 (Shane Emmons) about 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-darwin10.7.1]
Backport:
[ruby-core:<unknown>]

Description

=begin
SImilar to the issue here [[[http://redmine.ruby-lang.org/issues/3803]]], BigDecimal::ROUND_HALF_DOWN does not respect all the digits involved in the rounding of a number. For example:

(({BigDecimal("1.51").round(0, BigDecimal::ROUND_HALF_DOWN) == BigDecimal("2")})) returns false because it is ignoring the "1". The same fix that was done for ROUND_HALF_EVEN will need to be done here. I believe it has already been fixed in 1.9.3dev, so it should only need to be backported to 1.9.2 and 1.8.7.
=end


Related issues

Is duplicate of Backport193 - Backport #3803: BigDecimal::ROUND_HALF_DOWN/ROUND_HALF_EVEN behave incorrectly (disagree with JRuby and the rest of the world)Closed09/08/2010Actions

History

#1

Updated by mrkn (Kenta Murata) about 8 years ago

  • Status changed from Open to Assigned
  • Assignee set to mrkn (Kenta Murata)

=begin

=end

Updated by nahi (Hiroshi Nakamura) almost 8 years ago

  • Target version changed from 1.9.2 to 1.9.3

Updated by semmons99 (Shane Emmons) almost 8 years ago

Issue 3803 already handles this case. This issue can be closed with a reference to 3803.

Updated by mrkn (Kenta Murata) almost 8 years ago

  • Status changed from Assigned to Closed
  • Target version changed from 1.9.3 to 1.9.2

thank you for the notice, Shane.

Also available in: Atom PDF