Project

General

Profile

Actions

Bug #4056

closed

Crash in non-blocking read

Added by tmat (Tomas Matousek) almost 12 years ago. Updated over 11 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
Backport:
[ruby-core:33175]

Description

=begin
Ruby crashes when executing the attached script (a.rb).
See crash details attached in crash.log.
=end


Files

a.rb (2.4 KB) a.rb tmat (Tomas Matousek), 11/15/2010 05:51 AM
crash.log (3.98 KB) crash.log tmat (Tomas Matousek), 11/15/2010 05:51 AM
Actions #1

Updated by naruse (Yui NARUSE) almost 12 years ago

  • Status changed from Open to Feedback

=begin
I can't reprocuce.
Your a.rb has some strange part like start_server doesn't use its argument data.

Can you show reproducible code? or you confirmed exact this a.rb?
=end

Actions #2

Updated by naruse (Yui NARUSE) over 11 years ago

  • Status changed from Feedback to Rejected

I close this as Rejected since no feedback provided.
Please reopen this if it still happens on the latest version of ruby.

Actions

Also available in: Atom PDF