Project

General

Profile

Bug #3201

Backport request for r25932 to 1.9.1 branch (gem_prelude.rb)

Added by Cezary (Cezary Baginski) over 9 years ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.9.1p420 (2010-02-04 revision 26571) [x86_64-linux]
[ruby-core:29788]

Description

=begin
Please backport commit r25932 (dup required for force_encoding) in gem_prelude.rb.

I get the following error during gem operations:

Error loading gem paths on load path in gem_prelude
can't modify frozen string
internal:gem_prelude:69:in force_encoding'
<internal:gem_prelude>:69:in
set_home'
internal:gem_prelude:38:in dir'
<internal:gem_prelude>:76:in
set_paths'
internal:gem_prelude:47:in path'
<internal:gem_prelude>:286:in
push_all_highest_version_gems_on_load_path'

I cannot use earlier,recommended ruby 1.9.1 because I need the fix added in: r26568 (merged r26052 from trunk)

Thank you very much :)
=end

History

#1

Updated by sferik (Erik Michaels-Ober) over 8 years ago

=begin
This is a duplicate of #2404, which contains a patch.
=end

#2

Updated by jeremyevans0 (Jeremy Evans) 20 days ago

  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF