Project

General

Profile

Actions

Bug #18419

closed

TestObjectSpace#test_finalizer_thread_raise deadlocks

Added by vo.x (Vit Ondruch) 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 3.1.0dev (2021-12-21 master a6f76122a2) [x86_64-linux]
[ruby-core:106761]

Description

Testing Ruby 3.1 git|a6f76122a2, I have started to observe deadlock in TestObjectSpace#test_finalizer_thread_raise. I hope I am not just impatient, but I have not observer any issues testing previously with git|74b58dd690

Updated by vo.x (Vit Ondruch) 5 months ago

This might be outfall of the did_you_mean update, which was reverted. It seems that git|cdb7d699d0 passes fine. I'll keep observing.

Updated by vo.x (Vit Ondruch) 5 months ago

  • Status changed from Open to Rejected

I can't reproduce anymore.

Actions

Also available in: Atom PDF