Project

General

Profile

Bug #1606

TestRequire failure

Added by rogerdpack (Roger Pack) over 11 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
mingw 1.9.1p129
Backport:
[ruby-core:23800]

Description

=begin
105) Error:
test_require_invalid_shared_object(TestRequire):
IOError: closed stream
c:/dev/downloads/ruby_trunk/test/ruby/envutil.rb:132:in read'
c:/dev/downloads/ruby_trunk/test/ruby/envutil.rb:132:in
block in
assert_in_out_err'
=end

#1

Updated by yugui (Yuki Sonoda) over 11 years ago

  • Assignee set to usa (Usaku NAKAMURA)
  • Target version set to 1.9.2

=begin

=end

#2

Updated by usa (Usaku NAKAMURA) about 11 years ago

  • Status changed from Open to Assigned

=begin

=end

#3

Updated by usa (Usaku NAKAMURA) about 11 years ago

  • Priority changed from Normal to 5

=begin

=end

#4

Updated by usa (Usaku NAKAMURA) about 11 years ago

=begin
I cannot reproduce it.
Your zlib.so is broken?
=end

#5

Updated by rogerdpack (Roger Pack) almost 11 years ago

  • Status changed from Assigned to Rejected

=begin
appears to have gone away

C:\dev\ruby\downloads\ruby_trunk_debug_flags\test\ruby>ruby test_require.rb
Loaded suite test_require
Started
..........
Finished in 5.500000 seconds.

However, I would note that for some reason when I ran make test-all it would hang when it got to test_require. Will file as separate bug if I run into it again.
Thanks!
-r
=end

Also available in: Atom PDF