Project

General

Profile

Bug #15412

backport r66401 (Move autoload to toplevel)

Added by nagachika (Tomoyuki Chikanaga) 12 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
[ruby-dev:50706]

Description

チケットの backport 管理用です。

r66401 は ruby_2_4、ruby_2_5 でも autoload が module 内に書かれているので backport が必要かと思います。

Associated revisions

Revision 66401
Added by naruse (Yui NARUSE) 12 months ago

Move autoload to toplevel

So that classes which uses Net::HTTP with https can use OpenSSL
namespace for example exception classes like OpenSSL::SSL::SSLError.

Revision 4c426290
Added by nagachika (Tomoyuki Chikanaga) 11 months ago

merge revision(s) 66401: [Backport #15412]

    Move autoload to toplevel

    So that classes which uses Net::HTTP with https can use OpenSSL
    namespace for example exception classes like OpenSSL::SSL::SSLError.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_5@66877 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 66877
Added by nagachika (Tomoyuki Chikanaga) 11 months ago

merge revision(s) 66401: [Backport #15412]

Move autoload to toplevel

So that classes which uses Net::HTTP with https can use OpenSSL
namespace for example exception classes like OpenSSL::SSL::SSLError.

Revision 67305e79
Added by usa (Usaku NAKAMURA) 10 months ago

merge revision(s) 66401: [Backport #15412]

    Move autoload to toplevel

    So that classes which uses Net::HTTP with https can use OpenSSL
    namespace for example exception classes like OpenSSL::SSL::SSLError.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_4@66964 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 66964
Added by usa (Usaku NAKAMURA) 10 months ago

merge revision(s) 66401: [Backport #15412]

Move autoload to toplevel

So that classes which uses Net::HTTP with https can use OpenSSL
namespace for example exception classes like OpenSSL::SSL::SSLError.

History

Updated by nagachika (Tomoyuki Chikanaga) 11 months ago

  • Backport changed from 2.4: REQUIRED, 2.5: REQUIRED to 2.4: REQUIRED, 2.5: DONE

ruby_2_5 r66877 merged revision(s) 66401.

Updated by usa (Usaku NAKAMURA) 10 months ago

  • Backport changed from 2.4: REQUIRED, 2.5: DONE to 2.4: DONE, 2.5: DONE

ruby_2_4 r66964 merged revision(s) 66401.

Also available in: Atom PDF