Project

General

Profile

Bug #15365

backport r62776 (test_iseq.rb: skip iseq with coverage)

Added by nagachika (Tomoyuki Chikanaga) about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
[ruby-core:90219]

Description

This is a ticket for backport management.
r62776 seems required to get rid of failure in some CI environments.

Associated revisions

Revision 62776
Added by nobu (Nobuyoshi Nakada) over 1 year ago

test_iseq.rb: skip iseq with coverage

  • test/ruby/test_iseq.rb (test_to_binary_with_objects): #to_binary does not support iseq compiled with coverage, just skip.

Revision f35b27b5
Added by nagachika (Tomoyuki Chikanaga) about 1 year ago

merge revision(s) 62776: [Backport #15365]

    test_iseq.rb: skip iseq with coverage

    * test/ruby/test_iseq.rb (test_to_binary_with_objects): #to_binary
      does not support iseq compiled with coverage, just skip.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_5@66131 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 66131
Added by nagachika (Tomoyuki Chikanaga) about 1 year ago

merge revision(s) 62776: [Backport #15365]

test_iseq.rb: skip iseq with coverage

* test/ruby/test_iseq.rb (test_to_binary_with_objects): #to_binary
  does not support iseq compiled with coverage, just skip.

History

Updated by nagachika (Tomoyuki Chikanaga) about 1 year ago

  • Backport changed from 2.4: DONTNEED, 2.5: REQUIRED to 2.4: DONTNEED, 2.5: DONE

ruby_2_5 r66131 merged revision(s) 62776.

#2

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of Bug #14959: Writing a "link_to" method and a "url_helper" with a request parameter under certain "if else" statement in Rails helper crashes with KERN_INVALID_ADDRESS at 0x0000000000000000 added
#3

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of deleted (Bug #14959: Writing a "link_to" method and a "url_helper" with a request parameter under certain "if else" statement in Rails helper crashes with KERN_INVALID_ADDRESS at 0x0000000000000000)

Also available in: Atom PDF