Project

General

Profile

Bug #13699

Multiple maps over lazy enumerator yielding multiple values in 2.4.x causes crash

Added by alekstorm (Alek Storm) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:81837]

Description

Enumerator.new{|e| e.yield(5, 6)}.
  lazy.
  map{|x,y| 5}.
  map{|z| 5}.
  to_a

Tested and working in 2.1-2.3. Note that this is the absolute minimal input required to trigger the bug.


Related issues

Is duplicate of Ruby master - Bug #13648: [PATCH] Nested map of Enumerator::Lazy with packed values gives wrong resultClosedActions
#1

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Is duplicate of Bug #13648: [PATCH] Nested map of Enumerator::Lazy with packed values gives wrong result added
#2

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: DONTNEED, 2.3: DONTNEED, 2.4: REQUIRED
  • Status changed from Open to Closed

Updated by nagachika (Tomoyuki Chikanaga) over 2 years ago

  • Backport changed from 2.2: DONTNEED, 2.3: DONTNEED, 2.4: REQUIRED to 2.2: DONTNEED, 2.3: DONTNEED, 2.4: DONE

ruby_2_4 r59363 merged revision(s) 59056.

Also available in: Atom PDF