Project

General

Profile

Bug #13432

set_trace_funcにproc->is_from_method = TRUEのオブジェクトを渡し、SystemStackErrorを発生させるとRubyVMが停止する

Added by masato_hi (Masato Hi) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0dev (2017-04-13 trunk 58340) [x86_64-darwin16]
[ruby-dev:<unknown>]

Description

以下のコードのように、Method#to_procで作成したProcオブジェクトをset_trace_funcに設定しSystemStackErrorを発生させるとRubyVMが停止する。

def trace_method(event, file, line, id, binding, klass); end

set_trace_func method(:trace_method).to_proc

def stack_overflow
  stack_overflow
end

stack_overflow #=> RubyVM stops

以下のコードではこの問題は発生しない。

set_trace_func lambda {|event, file, line, id, binding, klass|
}

def stack_overflow
  stack_overflow
end

stack_overflow #=> stack level too deep (SystemStackError)

Related issues

Is duplicate of Ruby master - Bug #13425: Tracer.onにした状態でSystemStackErrorを発生させるとSegmentation faultClosedActions
#1

Updated by masato_hi (Masato Hi) over 3 years ago

  • Description updated (diff)

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Description updated (diff)

r59100では起きないようです。

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED

r58349 で修正済み。

#4

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Is duplicate of Bug #13425: Tracer.onにした状態でSystemStackErrorを発生させるとSegmentation fault added
#5

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Status changed from Open to Closed
#6

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Backport changed from 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED to 2.2: REQUIRED, 2.3: DONE, 2.4: REQUIRED

Updated by nagachika (Tomoyuki Chikanaga) over 3 years ago

  • Backport changed from 2.2: REQUIRED, 2.3: DONE, 2.4: REQUIRED to 2.2: REQUIRED, 2.3: DONE, 2.4: DONE

ruby_2_4 r59297 merged revision(s) 58334,58346,58349.

Also available in: Atom PDF