Project

General

Profile

Bug #12796

Segmentation fault at ~/.rvm/gems/ruby-2.3.0@global/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers/variable_name_checker.rb:10: [BUG]

Added by prasadsurase (Prasad Surase) about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin15]
[ruby-core:77435]

Description

Hi,

This is my first bug report so am sorry for missing out any wanted data.

I am using Ruby 2.3.0p0 with Rails 4.2.5. The ruby process crashes when running minitest tests for ActiveJob. The line causing the issue is
user.update({github_handle: 'somehandle'}). Commenting the line doesnt result in any ruby errors/crashes.

I have attached the Crash log with the entire stack trace rendered on the command line.

Thanks,
Prasad.


Files

ruby_2016-09-28-101123_Prasads-MacBook-Pro.crash (42.4 KB) ruby_2016-09-28-101123_Prasads-MacBook-Pro.crash Crash log prasadsurase (Prasad Surase), 09/28/2016 04:50 AM
error-stack-trace.txt (279 KB) error-stack-trace.txt cmd stack trace prasadsurase (Prasad Surase), 09/28/2016 04:55 AM

Related issues

Is duplicate of Ruby master - Bug #11928: Segmentation fault in did_you_mean extensionClosedActions
#1

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Is duplicate of Bug #11928: Segmentation fault in did_you_mean extension added

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Status changed from Open to Closed

It's an already fixed bug, and 2.3.1 has been released.

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Description updated (diff)

Also available in: Atom PDF