Project

General

Profile

Bug #12000

Crash report for 2.3.0

Added by RoxasShadow (Roxas Shadow) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin15]
[ruby-core:72902]

Description

Running RSpec tests on a RoR application, MRI 2.2.2 returned many failures due to an undefined method, while MRI 2.3.0 crashed with the following report. This happened only twice: once on CircleCI and once locally (OSX).

I attached the dump on my local machine.

The stack trace printed on CircleCI starts with:

/home/ubuntu/.rvm/gems/ruby-2.3.0@global/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers/variable_name_checker.rb:10: [BUG] Segmentation fault at 0x00000000000000

If you need it, I can post the whole stack trace.


Files

ruby_2016-01-18-121021_lifestream-2.crash (46 KB) ruby_2016-01-18-121021_lifestream-2.crash RoxasShadow (Roxas Shadow), 01/18/2016 01:44 PM

Related issues

Is duplicate of Ruby master - Bug #11928: Segmentation fault in did_you_mean extensionClosedActions
#1

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Is duplicate of Bug #11928: Segmentation fault in did_you_mean extension added

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Open to Closed

Thank you, already fixed in the trunk.

Also available in: Atom PDF