Project

General

Profile

Bug #11743

r52758 以降 config.guess がダウンロードできない

Added by ngoto (Naohisa Goto) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-dev:49388]

Description

r52758 以降、以下のエラーで configu.guess がダウンロードできず、./configure できなくなりました。

./configure --prefix=/XXXXX
downloading config.guess ... downloader.rb:168:in `rescue in download': failed to download config.guess (RuntimeError)
SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: https://gcc.gnu.org/git/?p=gcc.git;a=blob_plain;f=config.guess;hb=master
        from downloader.rb:115:in `download'
        from downloader.rb:43:in `download'
        from downloader.rb:204:in `block in <main>'
        from downloader.rb:203:in `each'
        from downloader.rb:203:in `<main>'
configure: error: cannot run /bin/bash tool/config.sub

手元の環境のruby(BASERUBY)その他が何だか怪しいのは確かですが、こういう場合もhttpsからhttpにフォールバックしてくれると助かります。

History

Updated by naruse (Yui NARUSE) over 3 years ago

証明書に問題を検出しているからこけているわけで、このよう場合に自動でfallbackするのはダメでしょう。
根本解決をせずに回避したいならば、wgetなりcurlなりで別に手で取ってきてtool下に置くなりするべきです。

さておき、gcc.gnu.orgは経験的にあまり強くないので、この機会にGitHubのmirrorから取得するようにしました。
もしかしたらこれでエラーが出なくなるかもしれません。

Updated by naruse (Yui NARUSE) over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF