Project

General

Profile

Bug #11722

Backport r52683 (Net::HTTP fix bug with "Expect: 100-continue" header)

Added by nagachika (Tomoyuki Chikanaga) about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-dev:49375]

Description

バックポート管理用チケットです。

r52683 の net/http の修正部分は差分のところだけみると 2.0.0 から同様のようなのでバックポートが必要かもしれません。


Related issues

Is duplicate of Ruby master - Bug #11719: Backport request r52683ClosedActions

Associated revisions

Revision ae2b1d2f
Added by nagachika (Tomoyuki Chikanaga) about 4 years ago

merge revision(s) 52683,52684: [Backport #11719] [Backport #11722]

    * lib/net/http.rb: Fixed regression for Net::HTTP::PUT with "Expect-100"
      header.

    * test/net/http/test_http.rb: added test.

    * Added missing reference of GitHub
      header. [fix GH-949]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@52738 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 52738
Added by nagachika (Tomoyuki Chikanaga) about 4 years ago

merge revision(s) 52683,52684: [Backport #11719] [Backport #11722]

* lib/net/http.rb: Fixed regression for Net::HTTP::PUT with "Expect-100"
  header.

* test/net/http/test_http.rb: added test.

* Added missing reference of GitHub
  header. [fix GH-949]

Revision 0f5bf067
Added by usa (Usaku NAKAMURA) about 4 years ago

merge revision(s) 52683,52684: [Backport #11719] [Backport #11722]

    * lib/net/http.rb: Fixed regression for Net::HTTP::PUT with "Expect-100"
      header.

    * test/net/http/test_http.rb: added test.

    * Added missing reference of GitHub
      header. [fix GH-949]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@52796 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 52796
Added by usa (Usaku NAKAMURA) about 4 years ago

merge revision(s) 52683,52684: [Backport #11719] [Backport #11722]

* lib/net/http.rb: Fixed regression for Net::HTTP::PUT with "Expect-100"
  header.

* test/net/http/test_http.rb: added test.

* Added missing reference of GitHub
  header. [fix GH-949]

History

#1

Updated by usa (Usaku NAKAMURA) about 4 years ago

  • Is duplicate of Bug #11719: Backport request r52683 added

Updated by nagachika (Tomoyuki Chikanaga) about 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE

Backported into ruby_2_2 branch at r52738.

Updated by usa (Usaku NAKAMURA) about 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE to 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE

ruby_2_1 r52796 merged revision(s) 52683,52684.

Also available in: Atom PDF