Project

General

Profile

Bug #11598

Ruby crash when I run calabash-android

Added by clintming@qq.com (clint ming) almost 4 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
Backport:

Description

Hi All,

I install the calabash-android. If the Chinese is included in the feature file, which is as below:
Feature: Login feature
Scenario: As a valid user I can log into my app
When I press "我的"
Then I can see "Not login interface"

It occurs the ruby crash when I execute the command calabash-android run xxx.apk.
I have tried install the ruby 1.9.3, ruby 2.0 or ruby 2.3. The problem is same. My OS is win7-32 or win7-64.

What is the problem and what should I do that I can use the calabash-android tool?


Files

crashInDos.jpg (282 KB) crashInDos.jpg fatal clintming@qq.com (clint ming), 10/16/2015 10:25 AM
RubyLibInstalled.jpg (151 KB) RubyLibInstalled.jpg ruby lib intalled clintming@qq.com (clint ming), 11/03/2015 06:55 AM

History

Updated by nagachika (Tomoyuki Chikanaga) almost 4 years ago

  • Tracker changed from Backport to Bug
  • Project changed from Backport22 to Ruby master

Hello, clint.

Could you provide full error messages in your command prompt?

Updated by clintming@qq.com (clint ming) almost 4 years ago

Where I can find more log information when it occurred? I can only find the error info on dos screen. Attachment is the ruby lib I have installed

#3

Updated by jeremyevans0 (Jeremy Evans) 3 months ago

  • Status changed from Open to Closed

Also available in: Atom PDF