Project

General

Profile

Bug #10951

insert WB in lep_svar_set() (r49898)

Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-dev:48898]

Description

バックポート管理用チケットです。

r49898 で lep_svar_set() に挿入された write barrier の部分は 2.1/2.2 にも同様の代入があるので必要ではないかと思います。

Associated revisions

Revision bc69a7df
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) 49898: [Backport #10951]

    * vm_insnhelper.c (lep_svar_set): add WBs.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@50899 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50899
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) 49898: [Backport #10951]

* vm_insnhelper.c (lep_svar_set): add WBs.

Revision 9af0f53f
Added by usa (Usaku NAKAMURA) over 4 years ago

merge revision(s) 49898: [Backport #10951]

    * vm_insnhelper.c (lep_svar_set): add WBs.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@50930 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50930
Added by usa (Usaku NAKAMURA) over 4 years ago

merge revision(s) 49898: [Backport #10951]

* vm_insnhelper.c (lep_svar_set): add WBs.

History

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: REQUIRED, 2.2: DONE

Partially backported into ruby_2_2 branch at r50899.

最初の差分の行は r49874 で導入された行で ruby_2_2 には存在しなかったため含めていません(see #10943).

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: REQUIRED, 2.2: DONE to 2.0.0: DONTNEED, 2.1: DONE, 2.2: DONE

ruby_2_1 r50930 merged revision(s) 49898.

Also available in: Atom PDF