Project

General

Profile

Bug #10898

Cannot compile Ruby 2.2.0 with configure error: something wrong with LDFLAGS=""

Added by pbhogan (Patrick Hogan) over 4 years ago. Updated 10 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]
[ruby-core:68282]

Description

To replicate, download and unzip Ruby-2.2.0
In terminal:
export LIBRARY_PATH=/foo/bar:$LIBRARY_PATH
./configure

Configure will fail with the following error:
configure: error: something wrong with LDFLAGS=""

It appears to be unimportant what LIBRARY_PATH is set to. As long as it is not empty, the error occurs.

If setting the LIBRARY_PATH environment variable is truly a problem, configure should at least give a more meaningful error instead of this unhelpful message that takes forever to track the cause of. :)

Platform: OSX 10.10.2
I know for a fact this happened with previous versions of OS X and previous versions of Ruby.

Thanks!

History

#1

Updated by jeremyevans0 (Jeremy Evans) 10 days ago

  • Status changed from Open to Closed

Also available in: Atom PDF