Project

General

Profile

Bug #9706

Date#<=> should use #< method(fixed at r45520)

Added by nagachika (Tomoyuki Chikanaga) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
-
[ruby-dev:48095]

Description

Date#<=> で #< メソッドを使って比較するようにする修正です。
trunk では r45520 で修正済みで、バックポート管理用にチケット化します。

Associated revisions

Revision 6eda5562
Added by usa (Usaku NAKAMURA) over 5 years ago

merge revision(s) 45520: [Backport #9706]

    * ext/date/date_core.c (d_lite_cmp): should compare with #<.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@46152 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 46152
Added by usa (Usaku NAKAMURA) over 5 years ago

merge revision(s) 45520: [Backport #9706]

* ext/date/date_core.c (d_lite_cmp): should compare with #<.

Revision 1c9a3e6e
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) r45520: [Backport #9706]

    * ext/date/date_core.c (d_lite_cmp): should compare with #<.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@46185 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 46185
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) r45520: [Backport #9706]

* ext/date/date_core.c (d_lite_cmp): should compare with #<.

History

Updated by usa (Usaku NAKAMURA) over 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED to 2.0.0: DONE, 2.1: REQUIRED

Backported into ruby_2_0_0 at r46152.

Updated by nagachika (Tomoyuki Chikanaga) over 5 years ago

  • Backport changed from 2.0.0: DONE, 2.1: REQUIRED to 2.0.0: DONE, 2.1: DONE

r45520 was backported into ruby_2_1 branch at r46185.

Also available in: Atom PDF