Project

General

Profile

Actions

Bug #955

closed

On windows, can't build outside of srcdir without ruby

Added by yugui (Yuki Sonoda) almost 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
Backport:
[ruby-core:20993]

Description

=begin
nmake does not recognize $(srcdir)/miniprelude.c and so on.
=end

Actions #1

Updated by usa (Usaku NAKAMURA) almost 14 years ago

=begin
I cannot reproduce it with rc1 and ruby_1_9_1.
Please explain the way to reproduce.
=end

Actions #2

Updated by yugui (Yuki Sonoda) almost 14 years ago

=begin
ko1 encountered this issue. He renamed the installed ruby to another name so that it would not be used as BASERUBY, and expand the tar.bz2 archive, and built ruby in another directory.

nmake did not recognize $(srcdir)/miniprelude.c, so it tried to generate ./miniprelude.c, and failed because it has no BASERUBY.
=end

Actions #3

Updated by usa (Usaku NAKAMURA) almost 14 years ago

  • Target version changed from 1.9.1 RC2 to 1.9.1 Release Candidate

=begin
hmm, same problems for newline.c, *.inc, and so on.
I have no plan to resolve these...
=end

Actions #4

Updated by yugui (Yuki Sonoda) almost 14 years ago

  • Target version changed from 1.9.1 Release Candidate to 1.9.1 RC2

=begin

=end

Actions #5

Updated by usa (Usaku NAKAMURA) almost 14 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
Applied in changeset r21280.
=end

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0