Project

General

Profile

Bug #6978

RDoc does not convert <Ruby_element>@<paragraph_name> to hyperlinks

Added by Lavir_the_Whiolet (Lavir the Whiolet) about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2012-09-02 trunk 36881) [x86_64-linux]
Backport:
[ruby-core:47419]

Description

With attached "test.rb" I issue command "rdoc test.rb" and gets some HTML doc. In the HTML doc I expect to see "Test@Some+Paragraph" replaced with a hyperlink with text "Some Paragraph at Test" and reference to "Some Paragraph" paragraph near Test class. But I only see "Test@Some+Paragraph" text in the HTML doc.


Files

test.rb (193 Bytes) test.rb Lavir_the_Whiolet (Lavir the Whiolet), 09/04/2012 06:44 PM

History

Updated by drbrain (Eric Hodel) about 7 years ago

  • Category set to lib
  • Status changed from Open to Assigned
  • Assignee set to drbrain (Eric Hodel)

Updated by drbrain (Eric Hodel) almost 7 years ago

  • Status changed from Assigned to Closed

I can't reproduce the failure with rdoc master. I believe it is fixed.

Also available in: Atom PDF