Project

General

Profile

Actions

Backport #5299

closed

Segmentation fault when using TweetStream gem in ruby 1.9.3

Added by dushyanth (Dushyanth Maguluru) almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:39380]

Description

=begin
=== Using tweetstream gem like this results in segfault:
TweetStream::Client.new('username','password').track('term1', 'term2') do |status|
puts "#{status.text}"
end

=== Environment:
ruby 1.9.3dev (2011-09-02 revision 33163) [x86_64-linux]

CentOS 5.2 (2.6.18-238.19.1.el5.centos.plus)

=== Attached files:
(1) List of gems installed (bundler's Gemfile)
(2) Ruby trace
(3) GDB trace
=end


Files

Gemfile (2.16 KB) Gemfile dushyanth (Dushyanth Maguluru), 09/09/2011 05:52 AM
ruby_trace.txt (33.4 KB) ruby_trace.txt dushyanth (Dushyanth Maguluru), 09/09/2011 05:52 AM
gdb_trace.txt (16.3 KB) gdb_trace.txt dushyanth (Dushyanth Maguluru), 09/09/2011 05:52 AM
Gemfile.txt (2.16 KB) Gemfile.txt dushyanth (Dushyanth Maguluru), 09/09/2011 05:55 AM

Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #5306: Application Hangs Due to Recent rb_thread_select ChangesClosed09/10/2011Actions

Updated by dushyanth (Dushyanth Maguluru) almost 11 years ago

Please note that this happens outside of a rails app as well.

Actions #3

Updated by nobu (Nobuyoshi Nakada) almost 11 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r33231.
Dushyanth, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


Actions #4

Updated by nobu (Nobuyoshi Nakada) almost 11 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport193
  • Status changed from Closed to Assigned
  • Assignee set to kosaki (Motohiro KOSAKI)
  • Priority changed from Normal to 6
  • Target version deleted (1.9.3)

Updated by kosaki (Motohiro KOSAKI) almost 11 years ago

Yes, it's regression. we need to backport it soon.

Updated by cfis (Charlie Savage) almost 11 years ago

Does "backport it soon" means backport it for the 1.9.3 release? I hope the answer is yes, its a pretty important bug for us.

Updated by kosaki (Motohiro KOSAKI) almost 11 years ago

Does "backport it soon" means backport it for the 1.9.3 release?  I hope the answer is yes, its a pretty important bug for us.

Yes, I mean backport it for 1.9.3p0.

Actions #8

Updated by kosaki (Motohiro KOSAKI) almost 11 years ago

  • Status changed from Assigned to Closed

This issue was solved with changeset r33258.
Dushyanth, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • Backport r33231.

  • thread.c (rb_thread_select): fix a typo to initialize efds
    properly. [Bug #5299] [ruby-core:39380]

Actions

Also available in: Atom PDF