Project

General

Profile

Backport #3853

Multiple IO problems when threading is used

Added by minad (Daniel Mendler) almost 10 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:32487]

Description

=begin

  • File.read(path) sometimes returns empty string although file is not empty
  • File.read(path, File.size(path)) somtimes returns nil although file is not empty

It seems as if the file reached eof. This happens only when threading is used. There seems to be some kind of race condition.

Ruby version is 1.8.7-p302 (on x86_64-linux and x86-linux).
This problem doesn't exist on 1.9 (tested with 1.9.1p429).
=end

#1

Updated by shyouhei (Shyouhei Urabe) almost 10 years ago

  • Status changed from Open to Feedback

=begin
This can be a real bug but we cannot check it without a reproducible code snippet.
=end

#2

Updated by minad (Daniel Mendler) almost 10 years ago

=begin
Well, until now I couldn't reproduce it in a simple snippet but it happens quite often in my application. I hoped that someone might have observed something similar. I try to create a snippet.
=end

#3

Updated by jeremyevans0 (Jeremy Evans) about 1 year ago

  • ruby -v deleted (ruby 1.8.7 (2010-08-16 patchlevel 302) [x86_64-linux])
  • Target version deleted (Ruby 1.8.7)
  • Status changed from Feedback to Closed
  • Description updated (diff)
  • Project changed from Ruby 1.8 to Backport187
  • Tracker changed from Bug to Backport

Also available in: Atom PDF