Project

General

Profile

Backport #3651

Crash when passing a block in an array indexer

Added by tmat (Tomas Matousek) about 9 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
[ruby-core:31610]

Description

=begin
This code crashes the interpreter:

z = lambda {}
x = [1,2,3,4,5]
x[1, 2, &z] += 1

[BUG] Segmentation fault
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]

-- control frame ----------
c:0002 p:-8883742 s:0004 b:0004 l:000003 d:000003 TOP
c:0001 p:0000 s:0002 b:0002 l:001d64 d:001d64 TOP


-- Ruby level backtrace information-----------------------------------------

[NOTE]
You may encounter a bug of Ruby interpreter. Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
=end


Related issues

Is duplicate of Ruby master - Bug #3372: Segfault when passing block_param to aref call with tOP_ASGN : foo[&b] += 21Closed05/31/2010Actions

History

#1

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Category set to core
  • Assignee set to yugui (Yuki Sonoda)
  • Priority changed from 6 to Normal

=begin

=end

#2

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Status changed from Open to Assigned

=begin

=end

#3

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Priority changed from Normal to 5

=begin

=end

#4

Updated by jeremyevans0 (Jeremy Evans) 3 months ago

  • Status changed from Assigned to Closed
  • Description updated (diff)

Also available in: Atom PDF