Project

General

Profile

Bug #3430

ENV 'MAKE' is not considered in the gem test.

Added by tarui (Masaya Tarui) over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2dev (2010-06-12 revision 28289) [i386-mswin32_90]
Backport:
[ruby-dev:41590]

Description

=begin
nmake install test-all
とした場合に、テストで環境変数を考慮していないため、

test_self_build_has_makefile(TestGemExtConfigureBuilder)
test_class_build(TestGemExtExtConfBuilder)
test_class_build(TestGemExtExtConfBuilder)

Expected "nmake", not "\"nmake\" > .installed.list".
などと言われて失敗します。

テストで環境変数を見るようにすべきでしょうか?
=end


Related issues

Is duplicate of Ruby master - Bug #3452: ENV 'make' is not considered in the rubygems test.Closedtarui (Masaya Tarui)06/19/201006/30/2010Actions
#1

Updated by tarui (Masaya Tarui) over 10 years ago

  • Status changed from Open to Closed

=begin
ruby-core向けでチケットを作り直したので、こちらは閉じます。

=end

Also available in: Atom PDF