Project

General

Profile

Backport #3235

Stack Traceback running irb on Linux

Added by rubys (Sam Ruby) about 9 years ago. Updated 8 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:29934]

Description

=begin
Reproduction instructions:

Execute "irb" from the command line with no parameters.

Result:

*** glibc detected *** irb: realloc(): invalid next size: 0x081e5f50 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7651803]
/lib/tls/i686/cmov/libc.so.6(realloc+0x10b)[0xb765375b]
irb(ruby_xrealloc+0x56)[0x8075646]

Full backtrace can be seen here:

http://intertwingly.net/projects/AWDwR3/checkdepot-188/section-19.html

Regression was introduced by:

http://redmine.ruby-lang.org/repositories/diff/ruby-18/lib/cgi.rb?rev=r27468
=end


Files

backtrace (9.15 KB) backtrace rubys (Sam Ruby), 05/03/2010 07:38 PM
ruby_envspace.patch (1.04 KB) ruby_envspace.patch Bugfix for environment-space scanner to only copy/move contiguous environment-variables. rubyjedi (Laurence Lee), 05/29/2010 06:05 PM

History

#1

Updated by rubys (Sam Ruby) about 9 years ago

=begin
Correction: regression was introduced by:

http://redmine.ruby-lang.org/repositories/diff/ruby-18/?rev=27468

Ruby revision 27466 works.
=end

#2

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

=begin
Hi,

At Sun, 2 May 2010 21:25:10 +0900,
Sam Ruby wrote in [ruby-core:29934]:

Reproduction instructions:

Execute "irb" from the command line with no parameters.

Seems running with scripts according to your backtrace.
I can't reproduce it on i686-linux and x86_64-linux without
parameters.

--
Nobu Nakada

=end

#3

Updated by rubys (Sam Ruby) about 9 years ago

=begin
I'm uploading a new backtrace that is running straight from the command line.

I am using rvm. For the backtrace I've provided, I've unset all environment variables that mention rvm (including IRBRC) except PATH. I've appended my environment variables at the end of the backtrace.
=end

#4

Updated by rubyjedi (Laurence Lee) about 9 years ago

=begin
This bug manifests itself on Fedora 12, x64 architecture. The root cause is the environment space not being contiguous.

Attached is a patch that corrects this issue. Chances are good the same root cause can also affect Ruby 1.9.2-head.

=end

#5

Updated by jeremyevans0 (Jeremy Evans) 8 days ago

  • ruby -v deleted (ruby 1.8.8dev (2010-04-24) [x86_64-linux])
  • Target version deleted (Ruby 1.8.8)
  • Status changed from Open to Closed
  • Description updated (diff)
  • Project changed from Ruby 1.8 to Backport187
  • Tracker changed from Bug to Backport

Also available in: Atom PDF