Project

General

Profile

Actions

Bug #3100

closed

Lockup in child after fork

Added by alk (Aliaksey Kandratsenka) about 12 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.8.7 (2010-01-10 patchlevel 249) [i486-linux]
[ruby-core:29263]

Description

=begin
I was using PTY.spawn and found a bug. I'm attaching a small testcase that at least on 2 my machines gives quite probable ruby process lockup in child.

I'm also attaching gdb backtrace of locked up child. It can be seen that we're stuck in NTPL's low-level lock that protects timer thread condition variable. So it looks like I'm doing fork at 'right' time, when this condition is being signaled in parent.

P.S. I'm categorizing it as core even though I can reproduce this only via PTY.spawn, 'cause pty.c looks very much innocent.
=end


Files

forktest.rb (548 Bytes) forktest.rb alk (Aliaksey Kandratsenka), 04/05/2010 08:14 PM
backtrace.txt (7.8 KB) backtrace.txt alk (Aliaksey Kandratsenka), 04/05/2010 08:14 PM
strace.log (36.1 KB) strace.log $ strace ruby forktest.rb 1 vo.x (Vit Ondruch), 08/30/2011 05:09 PM

Related issues 1 (0 open1 closed)

Related to Backport187 - Backport #2739: ruby 1.8.7 built with pthreads hangs under some circumstancesClosedshyouhei (Shyouhei Urabe)02/12/2010Actions
Actions

Also available in: Atom PDF