Project

General

Profile

Bug #278

segmentation fault on regexp

Added by Anonymous about 11 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
ruby -v:
-
[ruby-core:17799]

Description

=begin
ruby segfaults when rexml tries to parse an xml document (which i can't post).

tracing the execution, the failure is in:
c-call /usr/lib/ruby/1.8/rexml/parsers/xpathparser.rb:605 === Regexp

this is inside a case statement on 'path' variable which is a String with value '*' (without quotes)

coredump shows this:
#0 0xb7e7cbca in re_match_exec (bufp=0x8109fb0, string_arg=0xb481a0c0 "", size=1, pos=0,
beg=0, regs=0xbfc4c5ec) at regex.c:3981
#1 0xb7e80ab3 in ruby_re_search (bufp=0x8109fb0, string=0xb481a0c0 "
", size=1,
startpos=0, range=1, regs=0xbfc4c5ec) at regex.c:3314
#2 0xb7e7b36f in rb_reg_search (re=3076234480, str=3075252200, pos=0, reverse=0)
at re.c:918
#3 0xb7e7b705 in rb_reg_eqq (re=3076234480, str=3075252200) at re.c:1615
#4 0xb7e1ce6b in call_cfunc (func=0xb7e7b680 , recv=3076234480, len=8, argc=1,
argv=0x825809c) at eval.c:5749
=end

History

#1

Updated by nobu (Nobuyoshi Nakada) about 11 years ago

=begin
Hi,

At Wed, 16 Jul 2008 12:32:24 +0900,
Anonymous wrote in [ruby-core:17799]:

ruby segfaults when rexml tries to parse an xml document (which i can't post).

tracing the execution, the failure is in:
c-call /usr/lib/ruby/1.8/rexml/parsers/xpathparser.rb:605 === Regexp

this is inside a case statement on 'path' variable which is a String with value '*' (without quotes)

Didn't any other exceptions occur before the crash?

--
Nobu Nakada

=end

#2

Updated by nobu (Nobuyoshi Nakada) over 10 years ago

  • Status changed from Open to Feedback

=begin

=end

#3

Updated by shyouhei (Shyouhei Urabe) over 10 years ago

  • Assignee set to nobu (Nobuyoshi Nakada)
  • ruby -v set to -

=begin

=end

#4

Updated by marcandre (Marc-Andre Lafortune) almost 10 years ago

  • Status changed from Feedback to Rejected

=begin
Rejecting this issue since it lacks the information necessary to reproduce it. Since the regex engine has been changed in 1.9, we can only assume that this bug is no longer present.
=end

Also available in: Atom PDF