Project

General

Profile

Backport #2741

gets with large file is slow in windoze

Added by rogerdpack (Roger Pack) over 9 years ago. Updated 2 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:28160]

Description

=begin
Reposting from a different bug report...

# 10 MB
n = 100 * 1000 * 1000
puts "writing"
File.open("foo", 'wb'){|f| f.write(" " * n) }
puts "reading"
File.open("foo", 'rb') do |io|
io.gets
end

writing the file takes 1s, reading it takes 2000s, as it reads (in windows) in only in 4K bytes, so it is constantly resizing the string and recopying it. In Linux it has the same problem, but reads in 64K bytes, so the problem is much less.
=end


Related issues

Related to Backport187 - Backport #2722: gets on a large file takes a very very long timeClosedActions
Related to Ruby master - Bug #2742: IO#read/gets can be very slow in dozeClosed02/13/2010Actions

History

#1

Updated by jeremyevans0 (Jeremy Evans) 2 days ago

  • ruby -v deleted (ruby 1.8.8dev (2010-02-11 revision 26645) [i386-mingw32])
  • Status changed from Open to Closed
  • Description updated (diff)
  • Project changed from Ruby 1.8 to Backport187
  • Tracker changed from Bug to Backport

Also available in: Atom PDF