Project

General

Profile

Backport #1321

syck does not escape a plain scalar that starts with `

Added by rbrown (Richard Brown) over 10 years ago. Updated 9 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:23045]

Description

=begin
According to the YAML-1.0 spec ` is a reserved indicator, and plain scalars cannot start with a reserved indicator. For other indicators syck emits a double quoted scalar instead

Current Behaviour:
ruby -ryaml -e "puts '@'.to_yaml"
--- "@"
ruby -ryaml -e "puts '`'.to_yaml"
---
Intended Behaviour:
ruby -ryaml -e "puts '@'.to_yaml"
--- "@"
ruby -ryaml -e "puts '\
'.to_yaml"
--- "`"

This patch applies to trunk, the 1_8 and 1_8_7 and 1_8_6 branches
=end

Associated revisions

Revision 59991b6a
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@51801 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 51801
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

History

#1

Updated by jeremyevans0 (Jeremy Evans) 9 days ago

  • ruby -v deleted (ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux])
  • Status changed from Open to Closed
  • Description updated (diff)
  • Project changed from Ruby 1.8 to Backport187
  • Tracker changed from Bug to Backport

Also available in: Atom PDF